17 年历史,这个 RCE 漏洞已影响数个 Linux 系统

Miracle
1255
文章
68
评论
2020年3月10日11:54:55 评论 752字阅读2分30秒

一个影响点对点协议守护程序(Point-to-Point Protocol daemon,pppd)软件,并具有 17 年历史的远程代码执行(remote code execution,RCE)漏洞已对几个基于 Linux 的操作系统造成了影响。Pppd 软件不仅预先安装在大多数 Linux 系统中,而且还为流行的网络设备的固件提供 power。

17 年历史,这个 RCE 漏洞已影响数个 Linux 系统

该 RCE 漏洞由 IOActive 的安全研究人员 Ija Van Sprundel 发现,其严重之处在于,由守护程序软件的可扩展身份验证协议(EAP)数据包解析器中的逻辑错误所导致的堆栈缓冲区溢出漏洞。

根据 US-CERT 发布的咨询报告表示,该漏洞已被标记为 CVE-2020-8597。在严重程度方面,CVSS 则将其评为 9.8 分。

将一个 crooked EAP 打包程序发送到目标 pppd 客户端或服务器后,黑客就可以对此漏洞进行利用。其可以利用此漏洞并在受影响的系统上远程执行任意代码,从而接管系统的全部控制权。

而加重该漏洞严重程度的是,点对点协议守护程序通常具有很高的特权。这也就导致一旦黑客通过利用该漏洞控制服务器,就可以获得 root-level 的访问特权。

据 Sprundel 透露,该漏洞在 2.4.2 到 2.4.8 的 pppd 版本或过去 17 年中发布的所有版本中都一直存在。他已经确认以下 Linux 发行版已受到 pppd 漏洞的影响:

  • Ubuntu
  • Debian
  • Fedora
  • SUSE Linux
  • Red Hat Enterprise Linux
  • NetBSD

此外,还有以下设备也附带了受影响的 pppd 版本,并且容易受到攻击:

  • TP-LINK products
  • Synology products
  • Cisco CallManager
  • OpenWRT Embedded OS

建议用户们在补丁发布后尽快更新其系统,以规避潜在的攻击。

  • 版权声明: 发表于 2020年3月10日11:54:55
  • 转载注明:https://x1995.cn/7486.html
匿名

发表评论

匿名网友 填写信息

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: